Update to LinkProtect to help secure Gateway against attacks leveraging Adobe InDesign

by Barracuda Networks
Barracuda security researchers are warning of a recent surge in phishing attacks leveraging Adobe InDesign, a known and trusted document publishing system. Some of the attacks are targeted. Barracuda Email Protection includes a link
New

Introducing the Enhanced End User Interface with Advanced Authentication

by Barracuda Networks
We’re gradually rolling out the new user interface for end users. To fully embrace the enhanced security features of our new user interface, the admin on the account is requested to review and accept app permissions from Microsoft when
New

New React Platform Launch for End User Interface

by Barracuda Networks
Barracuda expands new React platform to Email Gateway Defense   Barracuda has been working extremely hard over the past year to bring all our solutions to a new, modern, front-end technology stack (ReactJS). You may have already seen the
Enhancement

NEW! Email Protection SaaS Plans

by Barracuda Networks
They’re here! We are excited to announce the general availability of our new email protection plans. As part of our mission to provide innovative security products that are easy to buy, deploy, and use, our new plans are designed to better
New

Report Messages and Provide Feedback from the Outlook Add-in

by Barracuda Networks
Now, you can use the Outlook Add-In to report suspicious messages and also provide feedback. When you click on the Outlook Add-In, you can simply submit the message as suspicious or choose to provide details as to why you think that message
Enhancement

Feedback on Reported Messages

by Barracuda Networks
When you report an email as incorrectly blocked or incorrectly delivered, in addition to the submission confirmation, you will also be asked to provide additional details as to why you think that message was incorrectly delivered or...
Enhancement

ESS will no longer support TLS v1.0 and TLS v1.1

by Barracuda Networks
On November 30, 2020, ESS will drop support for TLS v1.0 and v1.1. These are extremely old protocols that have numerous security vulnerabilities. If you are aware of any senders that are still using these protocols, advise them to upgrade.
Announcement